Вышел npm 2.0.0

22 сентября 2014

Менеджер пакетов npm для Node.js обновился до версии 2.0.0. Выход мажорной версии связан с командой run-scripts в которую теперь можно передавать аргументы — это изменение обратно несовместимо, поэтому, согласно политике semver, была увеличена мажорная версия. Среди прочих изменений: переход на semver@4.0, исключающий не готовые к релизу пакеты при указании диапазонов версий в package.json; введение областей видимости реестров пакетов (scopes); до версии 0.8 повышена минимально допустимая версия Node.js. Читайте подробнее в официальном блоге проекта.

Заметили важную новость?

Присылайте к нам в редакцию — wst@web-standards.ru

Перейти к началу